Simple Sony LBT-D107R Compact Shelf Stereo System static

This forum is for the discussion of music related hardware. This includes turntables, amplifiers, mixers, speakers and any other music related accessories.

Moderator: Guild Moderators

Post Reply
Sheldon2
Level 1
Level 1
Posts: 1
Joined: Sat Feb 01, 2014 3:29 am

Simple Sony LBT-D107R Compact Shelf Stereo System static

Post by Sheldon2 » Sat Feb 01, 2014 3:37 am

I just wanted something simple to plug my Auto Technica into to listen to my records. Nothing fancy. I have a cheap RCA unit that makes an annoying humming noise inside the unit but plays the records fine.But wanted something else because of the humming noise. I got this Sony unit and I can barely hear the music behind all of the static. The person that sold it to me said it was in working order when he shipped it.
I don't know enough to know where the problem is originating from and if it can be fixed easily - is it the speakers? Is it the wires? Is it the unit where the wires go in? I don't need anything fancy, but it's hard to find these simple units with phono input.

If neither of these is going to play my records, can you recommend something new that is simple, $200 or less, that will have a phono input?

User avatar
CactusCowboy
R.C.Guild-M-SMR
R.C.Guild-M-SMR
Posts: 10271
Joined: Thu Dec 15, 2005 6:25 pm
Location: Powell, Wyoming

RE: Simple Sony LBT-D107R Compact Shelf Stereo System static

Post by CactusCowboy » Sat Feb 01, 2014 3:24 pm

Hi Sheldon and welcome to the RCG.

Not sure if this is the source of the hum, but is your turntable ground wire hooked up to the amp? If not, that may be the problem.

User avatar
Graeme
R.C.Guild-M-SMR
R.C.Guild-M-SMR
Posts: 1937
Joined: Fri Feb 06, 2004 11:18 pm
Location: Spain
Contact:

RE: Simple Sony LBT-D107R Compact Shelf Stereo System static

Post by Graeme » Sat Feb 01, 2014 6:29 pm

I have a cheap RCA unit that makes an annoying humming noise inside the unit but plays the records fine.
This is usually the result of loose laminations in the mains transformer. As you say, it doesn't affect the sound through the speakers, just a mechanical noise from the amplifier. The cure could be as simple as tightening down the screws that hold the transformer to the chassis.

Post Reply

Return to “Hardware and Accessories Questions”

Who is online

Users browsing this forum: No registered users and 2 guests